SAP Knowledge Base Article - Public

3450726 - Overall status of the Value Contract does not change to "In Process" after creating a subsequent sales order.

Symptom

When creating a subsequent order from a Value Contract the overall status of the contract remains as "Open".

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open the Manage Sales Contracts app.
  2. Create a Value Contract.
  3. Navigate back to the initial screen of Manage Sales Contract app.
  4. Select the radio box beside the value contract that has just been created.
  5. Click create subsequent order.
  6. After creating the Subsequent Order, check the document flow and go back to the value contract.
  7. It is observed that the Overall Status of the value contract is "Open".
  8. The expectancy here is that the Overall Status should be set to "In Progress".

Cause

Expected system behaviour.

Resolution

  • There are only two status values that a Value Contract can be in, these are Open and Completed.
  • For a value contract to be set as completed, the user must set a reason for rejection.
  • To set the rejection reason:

    1. Open the Manage Sales Contract App.
    2. Open the relevant Value Contract.
    3. Click the change button.
    4. Select the line item of the contract.
    5. Press the Display items details button (which is located above the words "All Items").
    6. Once the item screen opens navigate to the Status tab.
    7. In the processing status, navigate to the Overall Status dropdown field.
    8. Select a reason in the Overall status.
    9. Click Save.
    10. Complete this for the other items if necessary.
    11. The overall status for the contract will now change from Open to Completed.

See Also

Sales Contract Management

Keywords

sales, contract, manage sales contract, value, value contract, overall status, overall, status, in process, open, completed , KBA , SD-SLS-OA-CCO-2CL , Customer Contracts (Public Cloud) , How To

Product

SAP S/4HANA Cloud Public Edition 2402