SAP Knowledge Base Article - Public

3450879 - Terminated Employee in SAP Successfactors Employee Central is Shown As Active in SAP Sales & Service Cloud v2

Symptom

You have terminated an employee in Employee Central, the change is replicated to Sales & Service Cloud V2 but the employee status is Active.

Environment

SAP Sales & Service Cloud V2 Integration with SAP Successfactors Employee Central

Reproducing the Issue

  1. Chose an active employee in Employee Central which is replicated , available in Sales & Service Cloud V2
  2. Terminate the employee in Employee Central
  3. Replicate the change manually or automatically to Sales & Service Cloud V2
  4. Open the employee in Sales & Service Cloud V2 , check the End Date is updated to terminated date
  5. But the Employee status is Active in Sales & Service Cloud V2

Cause

Once an Employee is terminated in EC , his/her validity gets ended in the V2 system(EndDate is updated to terminated date). But the status of an employee will still be ACTIVE because the status of an employee is not relevant in this case. 

Resolution

System works as per design. Terminated employee will not be able to raise any tickets from the SAP EC related applications which in principle meets the purpose of Employee Integration between EC & Service Cloud v2.

At the end an employee will have the status “ACTIVE” independent from his validity and will have the status “DELETED” if heshe was depersonalized via Data Protection & Privacy. No other employee status is supported.

Keywords

KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-EMP , Employee for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0