SAP Knowledge Base Article - Public

3451373 - Error: Unable to process your request for crystal report in BI launchpad.

Symptom

  • Unable to view a Crystal Report that requires more time to run in BI Launchpad
  • Getting error: Unable to process your request 
  • Observed error in Apache logs:

[Tue Mar 05 09:34:55.776246 2024] [proxy_ajp:error] [pid 1180:tid 1336] (70007)The timeout specified has expired: [client 10.134.2.117:60902] AH00878: read response failed from [::1]:8009 (localhost:8009), referer: 

Environment

  • SAP BusinessObjects Business Intelligence Platform (BI) 4.x
  • SAP Crystal Server 2020
  • All supported Operating System

Reproducing the Issue

  1. Login to BI LaunchPad.
  2. View a Crystal Report which have more data.
  3. Getting error

Cause

  • Processing timeout occurs on Apache server while viewing the report.

Resolution

  • Apache has a limit on maximum request body size and is rejecting the request
  • Increase the LimitRequestBody Directive on the Apache Server
  • See Apache documentation for more information on how this can be changed

Note: Apache is a 3rd party product, and SAP is unable to provide assistance on modification of this parameter.

Keywords

crystal report, Unable to process your request, BI launchpad, apache, timeout , KBA , BI-BIP-CRS-FUN , Admin, Viewing & Scheduling Reports , Problem

Product

SAP Crystal Server 2011