SAP Knowledge Base Article - Public

3451412 - Products Registered with Equipment Dependency Do Not Work

Symptom

During the registered product with equipment dependency replicated from S/4Hana to C4C, you might get the following error in the inbound payload message processing:

Either Parent Installation Point or Parent Registered Product is supported

Error details for entity: sap.crm.registeredproductservice.entity.registeredProductS4ReplicationMessageIn:

"message": "{\"error\":{\"code\":\"service-object.3000\",\"message\":\"Some input values are invalid\",\"details\":[{\"code\":\"service-object.3023\",\"message\":\"Either Parent Installation Point or Parent Registered Product is supported\",\"target\":\"{parentInstallationPoint}\"}],\"target\":\"/sap/c4c/api/v1/registered-product-service/registeredProducts/xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx\"}}"

Environment

SAP Cloud for Sales Version 1

SAP Cloud for Sales Version 2

Reproducing the Issue

In S/4Hana, When you replicate a registered product assigned to a Functional Location (e.g. t-code IE02), it works; but if you try to send by assigning it to another registered product, the error mentioned is raised in C4C.

Simulated Steps in S/4Hana:

  1. Open the change equipment t-code: IE02
  2. Open the corresponding Equipment ID
  3. Go to Structure tab
  4. Click on Change InstLoc icon under Structuring panel
  5. Set the new value thru Superior Object 
  6. Confirm

The new Superord Equip. and Functional Loc. will be displayed.

Cause

You might noticed that it comes with both functional location and registered product assigned as parent nodes at a hierarchical level.

In S/4HANA when an equipment is assigned to another equipment, it automatically drags the functional location and it cannot be modified or removed.

 

Resolution

In CNS, both Registered Product and functional location cannot be assigned as a parent of another Registered Product or Functional Location.

See Also

This is the same behavior for SAP Cloud for Customer version 1 and version 2.

For V2, you can still apply an alternative solution which should not be considered as final solution given by SAP;

By validating that if the equipment brings functional location and registered product as parent, it will only consider the registered product (screenshot as reference).

Keywords

parentInstallationPoint;Registered Product; parentInstallPointDisplayId;parentRegisteredProductDisplayId  , KBA , CEC-CRM-RPD , Registered Products for SAP Sales/Service Cloud , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0

Attachments

iflow_equipament.jpg