SAP Knowledge Base Article - Public

3451426 - Same Product Cannot Be Entered Twice In Quote Quick Add Feature

Symptom

Generic and copy feature functionality prevents the addition of duplicate items.

* The Image/data in this KBA come from demo systems, sample data, or SAP internal systems. Any resemblance to real data is purely coincidental. *

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: Sales quote is created in the system with the existing product XXXXXX, where XXXXXX stands for the Product ID or Product Description.

  1. Go to Sales work center.
  2. Go to Sales Quotes view.
  3. Search and open any sales quote.
  4. Go to Product facet.
  5. In the search bar, click on the value search icon.
  6. Select the row with the Product XXXXXX.
  7. Click twice on the Product XXXXXX row.
  8. Product XXXXXX is added on the products facet
  9. Again, search and select same Product XXXXXX from suggestion.
  10. Observation is that Product XXXXXX is not added again. 

Cause

Search icon in the search bar of a product facet is a generic search and a copy feature.

The selected product is already existing as one of the item in rows. Hence, search of the same product prohibits the search result/addition of the same product second time. 

Resolution

Use "Add" button on the products facet instead of search option, for adding Product XXXXXX already existing in the sales quote.

Keywords

Generic search, Add, copy feature, Product, Items , KBA , LOD-LE-CQP , Customer Quote Processing , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions

Attachments

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