Symptom
Customer is facing the error message below on web service message monitoring.
Error message:
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"code\":\"service-object.3000\",\"message\":\"Some input values are invalid\",\"details\":[{\"code\":\"service-object.3003\",\"message\":\"Enter Customer\",\"target\":\"{customer}\"}],\"target\":\"/sap/c4c/api/v1/registered-product-service/registeredProducts\"}}"
}
]
}
Environment
SAP Sales Cloud Version 2 Integration with SAP ERP / SAP S4HANA.
SAP Service Cloud Version 2 Integration with SAP ERP / SAP S4HANA.
Reproducing the Issue
In CNS,
- Go to "Settings".
- Go to "All Settings" tab.
- Under Integration tab, go to "Message Monitoring".
- Search for the message ID: XXXXXXXXXXXXXXX.
- Check the error message.
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"code\":\"service-object.3000\",\"message\":\"Some input values are invalid\",\"details\":[{\"code\":\"service-object.3003\",\"message\":\"Enter Customer\",\"target\":\"{customer}\"}],\"target\":\"/sap/c4c/api/v1/registered-product-service/registeredProducts\"}}"
}
]
}
Cause
Customer have not maintained the maintain value mapping for party role.
Resolution
Customer needs to maintain value mapping for party role. After that they can restarted the message and it will process successful.
Keywords
Registered product replication, mapping, party role, , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , How To