Symptom
Error message found during registered product replication:
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"code\":\"service-object.3000\",\"message\":\"Some input values are invalid\",\"details\":[{\"code\":\"service-object.3003\",\"message\":\"Enter Customer\",\"target\":\"{customer}\"}],\"target\":\"/sap/c4c/api/v1/registered-product-service/registeredProducts\"}}"
}
]
}
Environment
- SAP Sales Cloud Version 2 Integration with SAP ERP / SAP S4HANA.
- SAP Service Cloud Version 2 Integration with SAP ERP / SAP S4HANA.
Reproducing the Issue
- Go to "Settings".
- Go to "All Settings" tab.
- Under Integration tab, go to "Message Monitoring".
- Search for the message ID: XXXXXXXXXXXXXXX.
- Check the error message.
Cause
There are multiple causes:
- Sending Customer or Individual Customer in the payload - but the value mapping for the partyrole is not maintained in the system
- Replicating the registered product without Customer or Individual Customer
Resolution
- Maintain value mapping for party role(local code 1001) and restart the failed message.
- Its not possible to replicate the registered products without Customer or Individual Customer. Use determinations to fill with dummy customer id if it is missing or not sent in the incoming payload
Keywords
"service-object.3000"; "Some input values are invalid\" ; "Enter Customer" ; "registeredProductS4ReplicationMessageIn" , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem
SAP Knowledge Base Article - Public