SAP Knowledge Base Article - Public

3451817 - Generative AI for Case Summary comes up in English even when a user logs into Service Cloud V2 in another language other than English

Symptom

  • Case summary is show up in English while user is logged in Dutch, German or any other supported language.
  • The user anticipates that the initial generative text will be in the language that aligns with the user's logged-in preference. 

Environment

  • SAP Service Cloud Version 2 1.0
  • SAP Sales Cloud 2 1.0

Reproducing the Issue

  1. Log on the tenant with a preferred non-English language
  2. Go to Cases, and open a case that contains enough information for the AI to evaluate
  3. Go to the tab "General" and try to generate a summary (the setting must be enabled)

Alternative steps:

  1. Log on the tenant with a preferred non-English language
  2. Go to Settings -> Generative AI 
  3. Go to Case Summary
  4. Perform a Test Console -> text is generated in English

Cause

System is working as designed

Resolution

  • Generative AI features are tested only for English language texts.
  • When the user logs in using a different language, they can utilize the translation option to translate the summary into the language they are logged in with.

See Also

Case Summary

Keywords

Generative, Artificial Intelligence, AI, Case, Summary, English, default , KBA , CEC-CRM-ML , Machine Learning for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0