Symptom
When trying to resubmit a document in the Output History tab, the system is showing the following error message:
500 SAP Internal Server Error
Environment
SAP Business ByDesign
Reproducing the Issue
This error may occur for all the document. The following is an example for customer invoice.
- Go to the Customer Invoicing work center.
- Then go to the Invoice Documents view.
- Show All Invoice Documents.
- Search for the affected Document ID.
- Click Edit and then View All.
- Go to Output History Tab.
- Click Resubmit.
- Click Resubmit on the pop-up.
Cause
The error may occur due to following reasons:
- Case1: This error message is occurring because the Transformation at the Account Leve. If the proper Transformation is not maintained, the error message will occur.
- Case2: This error message is occurring because the used Transformation to resubmit is "Obsolete".
Resolution
Case 1:
Please follow the below steps to remove the transformation at account level or maintain the correct transformation.
- Go to the affected Account and click View All button.
- Click Communication tab then select Collaboration tab.
- Select Business Document Name of the related Business Object.
- Remove or maintain the correct Transformation.
- Then try to Resubmit the Document.
Case 2:
It is possible to choose a valid Transformation to resubmit the document in the pop-up window of Resubmit. Or please follow the below steps to active the Used Transformation.
- Go to Application and User Management -> Common Master Data Variant Configuration.
- Locate the configuration for the issued Transformation and click Edit.
- Find the issued Transformation.
- Click Activate.
See Also
Keywords
Error, Not Being Able to, Unable To, Cannot, Resubmit, Document, 500 SAP Internal Server Error, Output History, Transformation , KBA , AP-RC-OUT , Output Management , How To