Symptom
Customer is facing the error message below on Message Monitoring
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"message\":\"Lifecycle status is initial. Please provide a value.\",\"code\":\"sap.crm.md.service.businessPartnerService.businessPartnerMessage.lifeCycleStatusInitial\",\"target\":\"{lifeCycleStatus}\"}}"
}
]
}
Environment
- SAP Sales Cloud and SAP Service Cloud Version with S/4 Hana
Reproducing the Issue
In CNS,
- Go to "Settings".
- Go to "All Settings" tab.
- Under Integration tab, go to "Message Monitoring".
- Search for the message ID: xxxxxxxxxxxxxxxxx.
- Check the error message "Lifecycle status is initial. Please provide a value."
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"message\":\"Lifecycle status is initial. Please provide a value.\",\"code\":\"sap.crm.md.service.businessPartnerService.businessPartnerMessage.lifeCycleStatusInitial\",\"target\":\"{lifeCycleStatus}\"}}"
}
]
}
Cause
The reason for the error "Lifecycle status is initial. Please provide a value." is due to missing data maintained for Employment Information at SF side.
Resolution
Please ensure you have all data maintained properly before replicate them to C4C. The payload after mapping should contain the Validity data and employee type:
payload sample:
"employeeTypes": [
{
"id": "11eeaa47-29b7-e49e-afdb-81462c020a00",
"isInternalEmployee": true,
"validFrom": "2024-01-03",
"validTo": "9999-12-31"
Keywords
Employee, Lifecycle Status, Lifecycle status is initial. Please provide a value , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , How To