Symptom
When filtering for a Sales Order in the Data Source CRMSLOIB, the Sales Order ID is displayed as #.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Business Analytics Work Center.
- Go to Design Data Sources View.
- Search for the Data Source CRMSLOIB.
- Mark the Data Source CRMSLOIB.
- Select Preview button.
- Select the View Icon.
- In the Row fields section, select the '+' Icon.
- In the Row selection, search for Sales Order.
- Mark the Sales Order option.
- Select Ok button.
- Select the Selection Icon.
- In the Sales Order field, enter the Sales Order ID ABC. (where ABC represents the Sales Order ID)
- Select Apply button.
The Sales Order ID is displayed as #.
Cause
The List Price was not maintained for the Items in the Sales Orders ABC, therefore the Sales Order ID is displayed as # in the Data Source CRMSLOIB as the system is able to identify that Items were maintained for the document, however they are inconsistent due to mandatory price information missing.
Resolution
This is currently a standard system behavior
In this case, we kindly recommend to always maintain a valid List Price information during the creation of the Sales Order document.
Keywords
Data Source CRMSLOIB, CRMSLOIB, Sales Order, ID, #, Sales Order Item , KBA , AP-SLO-SO-ANA , Analytics , AP-SLO-SO , Sales Order , How To