SAP Knowledge Base Article - Public

3452826 - E-Verify Case Details Error - Onboarding

Symptom

When user clicks on E-Verify Case Details in the Dashboard, they are getting error: Server was unable to understand the URI of your OData API request, which contained the invalid character text sequence of: [[2222222222222], [CM]] . Please check the correctness of your query syntax, especially for unexpected whitespace or punctuation. For API syntax requirements consult https://help.sap.com/docs/SAP_SUCCESSFACTORS_PLATFORM/d599f15995d348a1b45ba5603e2aba9b/a37167b95b504ca9b484c8e19e2c26bb.html 

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Go to Onboarding Dashboard
  2. Find the candidate "Sample candidate"
  3. Go to Form I-9 and E-Verify Section
  4. Click "E-verify Case Details"
  5. Error Message pop up. Server was unable to understand the URI of your OData API request, which contained the invalid character text sequence of: [[2222222222222], [CM]] . Please check the correctness of your query syntax, especially for unexpected whitespace or punctuation. For API syntax requirements consult https://help.sap.com/docs/SAP_SUCCESSFACTORS_PLATFORM/d599f15995d348a1b45ba5603e2aba9b/a37167b95b504ca9b484c8e19e2c26bb.html 

Cause

This could permission issue or oData 

Resolution

  1. Make sure user has permission to EVerifyData or EVerifyCaseeStatusDetails objects
  2. Make sure oData metadata has those objects
  3. Refreshing odata metadata and clearing browser cache.

Keywords

OBX, E-VerifyCaseStatus Details , KBA , LOD-SF-OBX-EVF , Everify , Problem

Product

SAP SuccessFactors Onboarding all versions