Symptom
When user clicks on E-Verify Case Details in the Dashboard, they are getting error: Server was unable to understand the URI of your OData API request, which contained the invalid character text sequence of: [[2222222222222], [CM]] . Please check the correctness of your query syntax, especially for unexpected whitespace or punctuation. For API syntax requirements consult https://help.sap.com/docs/SAP_SUCCESSFACTORS_PLATFORM/d599f15995d348a1b45ba5603e2aba9b/a37167b95b504ca9b484c8e19e2c26bb.html
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to Onboarding Dashboard
- Find the candidate "Sample candidate"
- Go to Form I-9 and E-Verify Section
- Click "E-verify Case Details"
- Error Message pop up. Server was unable to understand the URI of your OData API request, which contained the invalid character text sequence of: [[2222222222222], [CM]] . Please check the correctness of your query syntax, especially for unexpected whitespace or punctuation. For API syntax requirements consult https://help.sap.com/docs/SAP_SUCCESSFACTORS_PLATFORM/d599f15995d348a1b45ba5603e2aba9b/a37167b95b504ca9b484c8e19e2c26bb.html
Cause
This could permission issue or oData
Resolution
- Make sure user has permission to EVerifyData or EVerifyCaseeStatusDetails objects
- Make sure oData metadata has those objects
- Refreshing odata metadata and clearing browser cache.
Keywords
OBX, E-VerifyCaseStatus Details , KBA , LOD-SF-OBX-EVF , Everify , Problem