Symptom
- No Computer Telephony Integration (CTI) implementation detected.
- Clicking telephony icon triggers opening of Widget pane.
- Widget pane displays message: "This content is blocked. Please contact the site owner to resolve this issue."
Environment
- SAP Service Cloud Version 2 1.0
- SAP Sales Cloud Version 2 1.0
Reproducing the Issue
- Connect to the Service Cloud V2 tenant
- Navigate and click the CTI/Telephony button (Up right corner)
- CTI pane opens up
Cause
- Missing CTI implementation
- System is using dummy record http://my-cti-provider.com
- Missing Content Security Policy (CSP) entry
Resolution
- For Working CTI Implementation with Error:
- Ensure the Content Security Policy (CSP) is correctly maintained according to Knowledge Base Article (KBA) 3371582.
- For No CTI Implementation:
- Navigate to Settings -> All Settings -> CTI -> CTI Configuration.
- Disable the Live Interaction Widget Settings by toggling the switch to "Inactive."
- Save the changes, which will hide the telephony icon in the user interface (UI).
- Transition to Correct CTI Implementation:
- Replace the placeholder "http://my-cti-provider.com" with the actual Widget endpoint.
- Ensure the CSP is updated to accommodate the new URL.
See Also
3371582 - CTI Widget Content Blocked
Keywords
http://my-cti-provider.com, because it violates the following Content Security Policy directive: "frame-src data: *.google.com *.powerbi.com my-cti-provider.com, Browser's DevTool Console logs will display the error "Refused to frame 'xyz****' because it violates the following...Content Security Policy directive: "frame-src data:" , KBA , CEC-CRM-CTI , CTI for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0