Symptom
- When recommending a course to a user who has already been assigned this item, a warning message appears: "Your recommendation wasn't sent to these users (XX) because they are already aware of this course or can't access it."
- How to specify the exact reason, whether the employee has already been assigned the course or if they are unable to access it?
Environment
SAP SuccessFactors Learning
Reproducing the Issue
1. Log in to "My Learning" > Find Learning
2. Search for an item that is already assigned to a user > Click "Recommend".
3. The warning "Your recommendation wasn't sent to these users (XX) because they are already aware of this course or can't access it." appears.
Cause
The warning message is to inform that the user has already been assigned this item, so there is no need to recommend it again. This is the expected behavior of the system.
Resolution
Currently, the system does not support the display of different warning messages for the two potential reasons mentioned above.
The only method to ascertain the exact reason is for the administrator to manually verify the user's assigned items and library access.
Keywords
SAP SuccessFactors Learning, course recommendation, recommendation tile, peer recommendation, warning message. , KBA , LOD-SF-LMS-TIL , Landing Page and Tiles , Problem