SAP Knowledge Base Article - Public

3453444 - [Onboarding] - Rehire welcome email is not triggered

Symptom

  • When we select the candidate as accept as rehire with old employment, and complete the data review, The rehire welcome email is not triggered. 

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  • Candidate has landed into rehire verification step.
  • Complete the data review for the user. 
  • The rehire welcome email is not triggered to the candidate to complete the personal data collection step.

Cause

  • The ecEmailType picklist is incorrectly configured. 
  • The standard ecEmailType picklist is modified in picklist center. 

Resolution

  • For the EC Picklist ecEmailType, we must use the standard system generated External Codes.
  • The standard External codes cannot be modified. 
  • Go to Picklist center and review ecEmailType picklist. The external code values should be as highlighted in the image below - 

ecEmailType.png

Keywords

rehire welcome emai, ROOE, rehire with old employment, Onboarding, mail not triggered, email , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem

Product

SAP SuccessFactors Onboarding 2311