SAP Knowledge Base Article - Public

3453620 - Filter issue in Work queue - Onboarding 1.0

Symptom

When adding a filter and processing the Validate Hire Data step (Orientation) for an Onboarding, you are redirected back to the Dashboard. The previous filter is still applied, but as of this previous release, it's no longer visible on top of the dashboard.

Also, when opening the filter, the fields are empty and you cannot just close the page, as it will not react. You actively have to remove the filter line and then you have to save the filter to be able to close. Only then the filter is restored/removed and the full list with onboardees is visible.

Environment

SAP SuccessFactors Onboarding

Cause

Known issue already identified by Engineering team and being fixed.

Resolution

Before 1H 2023 release, behavior was the following:

When you wanted to remove the filter it was sufficient to click the "X" in the green bar, which now disappears after the validation step of an onboarding.
When you wanted to adjust the filter to another Department Code, you could just click the filter icon again and adjust the code. Since the fields are now set to blank after processing an onboarding, you have to enter all the fields again.

Engineering team is working on a fix for the current behavior, which is planned to be launched in 2411 release. You can consult your Account Executive or Customer Engagement Executive regarding it with following number: ONB-35018

Keywords

ONB-35018, onboarding, OBD, 1.0, filter, redirect, back, dashboard, not working, issue , KBA , LOD-SF-OBD , Onboarding , Problem

Product

SAP SuccessFactors Onboarding all versions