SAP Knowledge Base Article - Public

3453691 - 'Role-Mapped Skills' Import Error: 1. Competency is not successfully migrated to Talent Intelligence Hub **** 2. The entity JDMNG_GO_RoleEntity has a corrupted mapping JDMNG_GO_RoleSkillMappingEntity with external code X

Symptom

When attempting to import a Role-Mapped Skills file, receive an error:

1. Competency is not successfully migrated to Talent Intelligence Hub **** 2. The entity JDMNG_GO_RoleEntity has a corrupted mapping JDMNG_GO_RoleSkillMappingEntity with external code X

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Talent Intelligence Hub
  • SAP SuccessFactors Center of Capabilities

Reproducing the Issue

  1. Log in to SuccessFactors
  2. Navigate to Admin Center > Tools > Import and Export Data
  3. In the Select the action to perform dropdown, select Import Data
  4. Select the CSV File tab
  5. Locate the Select Generic Object field and select Role-Mapped Skills
  6. Populate all relevant details and select a file > Import
  7. Navigate to Admin Center > Tools > Scheduled Job Manager
  8. Locate the MDF Data Import job and select View Details
  9. Open the file and it shows the error

Cause

  • The system created two mappings for the same JDM ID
  • Blank IDs populated for JPB ID and/or WSM ID
  • The JDM/JPB record count does not match the Talent Intelligence Hub record count

Resolution

Product Engineering is investigating a solution.

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Workaround

The system created two mappings for the same JDM ID

This can be identified by running the Check Tool for CoCDuplicateCompetenciesMappedToSameJdmId. If errors are present, please review 3357239 - Error with Every competency name in Center of Capabilities is unique (Check ID: CoCDuplicateCompetenciesMappedToSameJdmId) - Talent Intelligence Hub.

Blank IDs populated for JPB ID and/or WSM ID AND The JDM/JPB record count does not match the Talent Intelligence Hub record count

To identify the issue, first download the JdmJpbMappingEntity file:

  1. Navigate to Admin Center > Tools > Import and Export Data
  2. In Select the action to perform, select Export Data
  3. In the Select Generic Object field, select JdmJpbMappingEntity
  4. In the Include Inactive Records field, select Yes
  5. Select Export
  6. Select View Result
  7. Locate the job and select View Details
  8. Select Download Status to download the file

You can then compare the number of records between Manage Talent Intelligence Hub and the JdmJpbMappingEntity file. This can be used to confirm records for attributes (competencies and skills) and behaviors. The below sample shows a discrepancy in the attribute record counts (168 in Manage Talent Intelligence Hub and 157 from JdmJpbMappingEntity):

In the same file, you can also identify if there are blank IDs. The below sample picture shows missing IDs for the wsmId column:

Engineering will need to process a script to correct the above issues. Please create a case with Product Support under component LOD-SF-TIH-MIG with the following required details:

  • Data Center (URL of your login screen):
  • Company Instance ID (where to apply changes):
  • Approval

Keywords

success factors, sf, sfsf, tih, coc, cofc, competencies, skills, roles, mapped, mappings, missing, without, importing, files, cannot load, errors, failures, failed, KI2311 , KBA , LOD-SF-TIH-LIB , Attribute Library , LOD-SF-TIH-COC-ADM , Admin Center, Settings, Permissions , LOD-SF-MDF-IMP , Import and Export Issues , Known Error

Product

SAP SuccessFactors HXM Suite 2311