Symptom
Default Value rules, despite the fields which they check for being filled upon opening of Quick Create, are not working.
Environment
SAP Cloud For Customer
Reproducing the Issue
As an example (can happen in any Quick Create):
- Go to account OWL.
- Open new account QC view (accounts/new).
- Notice the fields which the rule checks for are initially filled.
- Notice how the fields that should be filled based on the rule do not show any value.
Cause
Fields utilizing information from /Root/SalesData/ have to check a separate Business Object for their values. This check is done after the rule pointing to the field checks for its value, making it so the rule sees an empty field when checking if it is true or not.
Resolution
When creating a rule, utilize a field which does not point to a separate business object.
As an example, /Root/Currency instead of /Root/SalesData/CurrencyCode.
Keywords
Value Rule, Default, SalesData, Quick Create, c4c , KBA , AP-RC-UIF-RT , UI Framework Runtime , Problem
Product
SAP Cloud for Customer core applications 2402
SAP Knowledge Base Article - Public