Symptom
You have a particular business requirement which is replicate the stocks with service teams with empty service technicians from ERP to C4C.
Your expectation is that C4C should not map employee id if the fields service org and service team are submitted from ERP
Environment
SAP Service and Sales Cloud Version 2
Reproducing the Issue
You might have maintained table view COD_V_PLANT_SRV in ERP (SM30) as 0 for SERVICE_TECH.
- Run RCOD_STOCK_EXTRACT Abap report
- The following error message is raised in C4C : ID mapping validation for XXX Employee ID failed
According to the error message the system tries to map the external employee id 0. But there is no mapping available because employee id 0 didn’t exists. And this is correct.
Cause
When you try to add products from Stock Location in ticket (Ticket TI -> Parts -> Add from Stock Location), the system gets only those stocks where logged in user is assigned as a Service Technician.
This is working as designed.
Resolution
In this scenario, stocks which are replicated with service teams and not having service technician won't be showed in Stock Location MD screen, where we show only those stocks which are available for the logged in employee. Therefore we don't see any other process incompatibility.
See Also
From Integration Scope, everything is set based on the standard functionality available in C4C. The requested change in functionality is therefore a custom functionality as standard UI will not display the said data. So the limitation mentioned described is not a bug, but that is the planned scope from standard integration content.
Keywords
StockLocationReplicationIn , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To