SAP Knowledge Base Article - Public

3454429 - {ONB) Rehire User Welcome Message Template is not triggered to some of the rehires - Onboarding

Symptom

  • Rehire User Welcome Message is not sending to all rehires.
  • Rehire users have unsubscribed to Email Services email list.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Cause

The users have unsubscribed from Email Services. Sample Logs below:

  • 09:08:31,496 INFO [EmailRecipientsBuilder] [123456] [<Company ID>,<Customer Name>,sfv4_STOCKPM7214.,dbPool68PRBY3T01,null,null,null,en_US]User: [USER ID HASH] has unsubscribed to Email Services. Hence removing from recipient list.

In Change User Email Notification Setting, the 'Email Notification' column is unchecked.

Comparing it with the data of the rehires who have received their welcome emails, the checkbox is checked.

Resolution

  • Please navigate to 'Change User Email Notification Setting' and ensure that the 'Email Notification' column checkbox is checked for the affected users.
  • If the user opted to unsubscribe to Email Services, then they are removed from the recipient lists, then this checkbox will be unchecked automatically.

See Also

3453444 - [Onboarding] - Rehire welcome email is not triggered

Keywords

Rehire Welcome Letter, Rehire Welcome Message, Email Services, Change User Email Notification Settings, Rehire email not triggered, Email Status, Unsubscribed, User: [USER ID HASH] has unsubscribed to Email Services. Hence removing from recipient list, Onboarding, Rehire, OBX, ONB, Onboarding 2.0, ONB2, EML, Email , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem

Product

SAP SuccessFactors Onboarding 2311

Attachments

Pasted image.png
Pasted image.png