Symptom
- Rehire User Welcome Message is not sending to some rehires.
- Rehire users have unsubscribed to Email Services.
Environment
SAP SuccessFactors Onboarding
Cause
The users have unsubscribed from Email Services. Sample Logs below:
- 09:08:31,496 INFO [EmailRecipientsBuilder] [123456] [<Company ID>,<Customer Name>,sfv4_STOCKPM7214.,dbPool68PRBY3T01,null,null,null,en_US]User: [USER ID HASH] has unsubscribed to Email Services. Hence removing from recipient list.
Resolution
In Company System and logo Settings page, there is a setting called "Restrict email notification preference settings to administrators only." which allows company admins to control the permission whether to allow users to set their notification preferences.
(Previously this setting was called "This option allows a company-wide setting on whether users will receive Email notifications. If 'checked', all users will receive Email on all workflow related process. If not checked, each user has an option to turn notification on/off.")
If the option "Send emails to me" is selected, all users will receive emails about all workflow and system generated processes.
To avoid this kind of issue, please select option "Send emails to me".
See Also
KBA: 3453444 - [Onboarding] - Rehire welcome email is not triggered
KBA: 2414180 - Notifications tab - Send emails to me / Read messages in the system
Keywords
Rehire Welcome Letter, Rehire Welcome Message, Email Services, Change User Email Notification Settings, Rehire email not triggered, Email Status, Unsubscribed, User: [USER ID HASH] has unsubscribed to Email Services. Hence removing from recipient list, Onboarding, Rehire, OBX, ONB, Onboarding 2.0, ONB2, EML, Email , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem
Product
Attachments
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SAP Knowledge Base Article - Public