SAP Knowledge Base Article - Public

3454828 - Previous Role-Specific Attributes Are Visible in Growth Portfolio after Employee Job Role Change

Symptom

After a job role change is processed for an employee, the old attributes (skills or competencies) are still visible in Growth portfolio together with new role-specific ones.

Environment

SAP SuccessFactors Talent Intelligence Hub

Reproducing the Issue

  1. Go to the Employee Growth portfolio and see a set of attributes (skills or competencies) that were populated from the relevant job role.
  2. Change the Employee job code to a different one with another set of skills or competencies mapped to the role.
  3. Go to the Employee Growth portfolio and see that 2 sets of attributes are displayed there (from the previous role and current one).

Cause

This is expected behavior: attributes will not be automatically removed from the Growth portfolio as per system design.

Resolution

Employee can manually remove unnecessary skills or competencies from the Growth portfolio.

If it is necessary to remove the attribute for all employees for whom the job code changed, the Growth Portfolio import option should be used. With this option, the Status of Attribute association will be marked as Inactive. The Standard integration template is available here: SuccessFactors Talent Intelligence Hub Growth Portfolio Import Template.

See Also

Using Talent Intelligence Hub - Importing and Exporting of Talent Intelligence Hub Entities 

Keywords

Talent Intelligence Hub, TIH, Growth portfolio, import, export, Integration Center, view attribute, job code, job role, success factors, sf, sfsf, attributes, competencies, skills, duplicates, duplicated, double, multiple , KBA , LOD-SF-TIH-POR , Capabilities Portfolio (Growth Portfolio) , LOD-SF-TIH-SKL , Skills Ontology , LOD-SF-TIH-LIB , Attribute Library , Problem

Product

SAP SuccessFactors HXM Suite 2311