SAP Knowledge Base Article - Public

3454885 - SAC AD : Application takes long time to save and ended with errors

Symptom

  •  On specific SAC tenant, story or application takes long time to save and then finally throws up error message :
    "Sorry, something went wrong. The system couldn't update your analytic application. Please try again, and if the problem persists, contact your system administrator
  • In Console : there is relevant error :
    POST https://xxxxx.yyy.hcs.cloud.sap/sap/fpa/services/rest/epm/contentlib?tenant=2 net::ERR_HTTP2_PROTOCOL_ERROR (anonymous)
  • In Network Trace, we could read the error :
    RestSession.xsjslib(00784) : RestSession.captureImpersonatedUserLicenseData() failed: WRANGLING : {"packageId":"sap.fpa.services.resource.core","objectName":"message_system","messageId":"UNAUTHORIZED_USER","args":["WRANGLING"],"message":"The user does not have the necessary authorization"

Environment

  • SAP Analytics Cloud (Enterprise) 2024.2.16

Cause

WRANGLING technical user doesn't have sufficient permission to impersonate when saving.

Resolution

The issue is fixed starting from 2024.4. The QRC2 2024 (2024.8) includes also the fix.

See Also

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Keywords

UNAUTHORIZED_USER, WRANGLING, anonymous, authorization, Analytics Designer, SAC LOD_ANA-AD , KBA , LOD-ANA-AD , Analytics Designer , Problem

Product

SAP Analytics Cloud all versions