Symptom
Personal Data Collection presented with error "Looks like something went wrong. Please try again or contact Product Support, if the problem persists".
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Log in as candidate
- Open Personal Data Collection Step
- Continue through portlets
- Click continue on JobInfo portlet
- Presented with error "Looks like something went wrong. Please try again or contact Product Support, if the problem persists".
- Cannot proceed to compensation portlet
Cause
The issue is caused because of the Object "ConfigUIMeta".
This Object is marked as a secured object
Resolution
- Navigate to Configure Object Definition
- Open object "ConfigUIMeta"
- Click Take Action
- Change Secured value to No
OR - Go to Manage Permission Role >
- Open OnboardingExternalUser role
- Click on Permission
- Miscellaneous Permission
- Enable (View/Edit) for "ConfigUIMeta"
- Save
- Once changed, try again to submit PDC
Keywords
Looks like something went wrong. Please try again or contact Product Support, if the problem persists, Error, PDC, Personal Data Collection, ConfigUIMeta, : Cannot invoke "com.successfactors.genericobject.bean.configui.model.ConfigUIMeta.getBaseObjectType()" because "meta" is null, , KBA , LOD-SF-OBX-PDC , Personal Data Collection , Problem