SAP Knowledge Base Article - Public

3455099 - Looks like something went wrong. Please try again or contact Product Support, if the problem persists. Error in PDC - Onboarding

Symptom

Personal Data Collection presented with error "Looks like something went wrong. Please try again or contact Product Support, if the problem persists".

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Log in as candidate
  2. Open Personal Data Collection Step
  3. Continue through portlets
  4. Click continue on JobInfo portlet
  5. Presented with error "Looks like something went wrong. Please try again or contact Product Support, if the problem persists".
  6. Cannot proceed to compensation portlet

Cause

The issue is caused because of the Object "ConfigUIMeta".
This Object is marked as a secured object

Resolution

  1. Navigate to Configure Object Definition
  2. Open object "ConfigUIMeta"
  3. Click Take Action
  4.  Change Secured value to No
    OR
  5. Go to Manage Permission Role >
  6. Open OnboardingExternalUser role
  7. Click on Permission
  8. Miscellaneous Permission 
  9. Enable (View/Edit) for "ConfigUIMeta"
  10. Save
  11. Once changed, try again to submit PDC

Keywords

Looks like something went wrong. Please try again or contact Product Support, if the problem persists, Error, PDC, Personal Data Collection, ConfigUIMeta, : Cannot invoke "com.successfactors.genericobject.bean.configui.model.ConfigUIMeta.getBaseObjectType()" because "meta" is null,  , KBA , LOD-SF-OBX-PDC , Personal Data Collection , Problem

Product

SAP SuccessFactors Onboarding 2311