SAP Knowledge Base Article - Public

3455410 - Language Adaptation for KUT fields are not showing after Transport

Symptom

The Language Adaptation for your KUT fields are not transported to the Target tenant even though they are maintained in the Source tenant.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Create the relevant Language Adaptation in the Source Tenant
  2. Transport the Language Adaptation to the Target Tenant
  3. Open the Language Adaptation in the Target Tenant
  4. The KUT fields are showing with empty translation.

Cause

These KUT fields were created manually via key user tools on Source and Target tenant, so they end up with different text pool ID in each tenant.

The transport for these text doesn't seem to work because they have different text pool ID's and thus are not regarded as the same texts on Source and Target systems.

They are two different change transactions, created independently, which characterizes two different texts inside the system and cannot be transported into another.

Resolution

Create the KUT field only on Source Tenant side first and then do a transport of the Change Transactions into the Target Tenant.

See Also

KBA 2604106 - Language Adaptation is not Working for a Key User Tool (KUT) Field  

Keywords

language adaptation, translation, key user tool field, kut, field definition, transport, transport management , KBA , AP-RC-TXA , C4C Text Adaptation , Problem

Product

SAP Cloud for Customer core applications 2402