Symptom
Whether the behaviour of the Timesheet Absence request and Dynamic Break valuation in below scenario is expected.
- Configuration = For X working hrs, Y min break is accrued.
- However when the employee requests Z hrs absence , Dynamic Break is also apply to Z (proportionally)
Environment
- Employee Central Cloud
- Timesheet
- Time Off
- Absence /Attendance
Reproducing the Issue
- Go to the timesheet
- Enter absence request
- the result of the requested absence posted is more than expected.
- For example:
- Configuration = For 6 hrs (X), 30 min break is accrued (Y).
- However when the employee requests 2 hrs absence (Z), 1h:40min is posted
- In-between the 2hrs requested lies the 30 min break.
- The customer expects 1h:30 min.
- Configuration = For 6 hrs (X), 30 min break is accrued (Y).
Cause
So far this is expected behavior as absence calculations do not consider attendances as of now. In the future, this might be enhanced, but it is not yet on the agenda.
Explanation:
While the absence is recorded, the system do not read the attendances. Hence, the system does not know, that no dynamic breaks are required. But, to gather the right amount of hours for absences, the breaks are generated as if the full work schedule is worked
Resolution
As a workaround the customer can define a manual break outside the absence overlapping the attendance to get the number of minutes right again.
Keywords
Dynamic Break Valuation, Time Attendance Valuation, , KBA , LOD-SF-EC-TIM-ABS , Absence error's - Calculations, Deductions, TT&ET , LOD-SF-TTR-TMS , Time Sheet , LOD-SF-EC-TMS-TV , Time Valuation - Collectors, Groups, In Lieu, AA2 , Product Enhancement