Symptom
It is not possible to pass Sales Order/Item under Revenue Assignment on Item Level when creating External Invoice Requests via webservice ManageCustomerInvoiceRequestIn.
Environment
SAP Business ByDesign
Cause
When creating an Invoice Request via the web service an External Customer Invoice Request is created.
The External Customer Invoice Request behaves like a Manual Invoice Request and cannot be linked to a preceding document such as a Sales Order, Service Order, Service Confirmation etc.
In the system, these documents are invoiced via the standard internal ByDesign processes e.g. via an Outbound Delivery Invoice Request, Sales Order Invoice Request, Service Order Invoice Request, Service Confirmation Invoice Request etc; and in this scenario the respective AccountingCodingBlockAssignment is linked automatically.
However when assigning the item to a Project Task it is needed to pass the AccountingCodingBlockTypeCode as PRO.
For example:
<AccountingCodingBlockAssignment>
<AccountingCodingBlock>
<AccountingCodingBlockTypeCode>PRO</AccountingCodingBlockTypeCode>
<ProjectReference>
<ProjectElementID>XYZ-123-4</ProjectElementID>
</ProjectReference>
</AccountingCodingBlock>
</AccountingCodingBlockAssignment>
Resolution
This is the current system behaviour.
You can find more information about the web service as follows:
- Go to the Application and User Management work center.
- Select the Service Explorer view.
- Select the Service ManageCustomerInvoiceRequestIn with the Operation Maintain customer invoice requests
- In the Details section, click on the Link for Documentation.
See Also
2066581 - In the New Manual Invoice Request, the Account Assignment Type as SLS -Sales Order is Missing
2977977 - How to set Reconciliation Account with Web Service 'ManageCustomerInvoiceRequestIn'
Keywords
Webservice, not possible, missing, Sales Order, Revenue. , KBA , SRD-CRM-INV , Customer Invoicing , Problem