SAP Knowledge Base Article - Public

3456533 - The Error Message "Business partner Service and Support Team ID XYZ must have organizational role code Customer Service" is Displayed When Changing the Service and Support team in a Service Order

Symptom

When changing the Service and Support team in the Service Order ABC, the error message "Business partner Service and Support Team ID XYZ must have organizational role code Customer Service" is displayed in the UI.

(where ABC represents the Service Order ID and XYZ represents the Org Unit ID)

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Order Work Center.
  2. Go to the Service Order Processing View.
  3. Filter for All Orders.
  4. Search for the Service Order ABC.
  5. Open, Select View All.
  6. Navigate to the General tab.
  7. In the Service and Support team field, enter the Org Unit XYZ.

The error message "Business partner Service and Support Team ID XYZ must have organizational role code Customer Service" is displayed in the UI.

Cause

The error message "Business partner Service and Support Team ID XYZ must have organizational role code Customer Service" is displayed for the document because the Service Order ABC was created before the Org Unit XYZ was valid in the system.

Following are the steps to check the Org Unit validity:  

  1. Go to the Organizational Management Work Center
  2. Go to the Org Structure View
  3. In the Currently selected date field, enter today's date
  4. Select Ok button
  5. Select the Find button
  6. In the search field, enter XYZ
  7. Select Locate button
  8. Navigate to the General tab

The Valid From date of the Org Unit XYZ is after the creation date of the Service Order ABC.

Resolution

In this case, we kindly recommend to change the Valid From date of the Org Unit XYZ to a date before the creation of the Service Order ABC.

Following is the process in order to change the Valid From date of the Org Unit in the system: 

  1. Go to the Organizational Management Work Center.
  2. Go to the Org Structure View.
  3. In the Currently selected date field, enter today's date.
  4. Select Ok button.
  5. Select the Find button.
  6. In the search field, enter XYZ. (where XYZ represents the Org Unit ID)
  7. Select Locate button.
  8. Select Edit button.
  9. In the Currently selected date field, enter today's date.
  10. Select Ok button.
  11. Navigate to the Timelines tab.
  12. In the Valid From column, change all dates to a date before the creation of the Service Order ABC. (where ABC represents the Service Order ID)
  13. Select Activate button.
  14. In the dropdown, select Activate Selected Structure.

A message indicating that the activation was completed will be displayed, and the Valid From in the General tab will be changed to the desired date.

After this process, we kindly ask you to maintain the Org Unit XYZ as the Service and Support Team in the Service Order document and then perform the Save action.

Keywords

Service Order, Org Unit, Service and Support Team, Business partner Service and Support Team ID, must have organizational role , KBA , SRD-CRM-SEO , Service Orders , How To

Product

SAP Business ByDesign all versions