Symptom
- When using Live Activity with Widget integration:
- Pressing the Telephony icon opens the Live Engagement iframe, which remains stationary.
- Clicking on the Productivity Icon (clock) causes a new iframe to take focus.
- This action results in the CTI widget content being unloaded.
Image/Data is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Open Live Activity with Widget integration.
- Press the Telephony icon to open the Live Engagement iframe.
- Note that the iframe remains stationary.
- Click on the Productivity Icon (clock).
- Observe that a new iframe takes focus.
- Notice that this action results in the CTI widget content being unloaded.
Cause
- Incorrect customer implementation
- Missing configuration
Resolution
- User can click in the middle of the iFrame where the widget loads to see it
- Alternatively, the administrator can set the Iframe to be a floating iframe:
- Go to Administrator
- Service and Social
- Live Activity Configuration
- Set the "Move and Resize Notification" to "Yes"
- Save the changes. At this point, the Telephony Iframe will be in the foreground.
Keywords
Live Activity, Agent Desktop, Side by Side, Widget Integration, Telephony Icon, Live Engagement, Iframe, Productivity Icon, CTI Widget, Content Unloaded , KBA , LOD-CRM-LA , Live Activity , LOD-CRM-SBS-AC , Agent Console Add-on , Problem
Product
SAP Cloud for Customer core applications 2402