Symptom
- Customer can't go through the Reverification Panel (I-94 form) and is getting error: "The following fields are required and must be filled in before you continue:
Please verify you are entering the correct date or have the employee supply another document. The process cannot continue if the dates are incorrect." - The person never traveled outside the States so that's why the DHS expiry date is in the past but has a valid work document.
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Logged in BizX
- Proxy as hiring manager
- Went to ONB Instance
- Reverification Process
- looked for affected candidate
- in I-9 - Updating and Reverification panel
- click next and that's when you get the error
Cause
expected behavior, I-9 Reverification requires updated expiration date hence it won't accept a document with expired date.
Resolution
Once you reach the I-94 expiration date, your status ends, even if the other documents remain valid. There is no grace period beyond your I-94 expiration date while in H-1B status. Once your status ends or your employment ends, you need to make arrangements to depart the United States as soon as possible.
Though the I-94 Form process is automated; as a result, you will receive a stamp in your passport indicating your status and the expiration date of the status. You will also receive a digital I-94 record that you can access through the U.S. Customs and Border Protection Opens in new window website.
See Also
Please see https://www.cbp.gov/sites/default/files/documents/502386%20-%20I-94%20Fact%20Sheet_OFO.pdf and https://hr.fullerton.edu/risk-management/faculty-staff-visas-permanent-residency/i94-grace-period.php#:~:text=Once%20you%20reach%20the%20I,States%20as%20soon%20as%20possible.
Keywords
The I-94 Form, Onboarding 1.0, I-9 reverification, in the past, DHS expiry date, ID, Onboarding 1.0, obd , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , How To