Symptom
Issue 1:
- Onboardee is not appearing in the onboarding dashboard and its landed in the BPE error tile with the error.
- [Error Code: 16]An error has occurred, please contact the system administrator
Issue 2:
- When trying to add new hire manually using "Add New Hire to Onboarding" page below error is received:
- Unable to insert data due to a server error. Please try again.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Initiate onboarding for a candidate from RCM or manually.
- Candidate does not appear in the onboarding dashboard.
- Go to "TO DO" icon in the top of the page
- Check the Business Process (BPE) error tile , you will see the below error for the candidate : [Error Code: 16]An error has occurred, please contact the system administrator
Cause
Cause 1:
- Picklist ecEmailType is not configured in Picklist Center
Cause 2:
- ecEmailType is configured incorrectly.
Resolution
Solution 1:
- Enable/configure the ecEmailType picklist in Picklist Center
- Kindly follow KBA 2894061 and make sure that the standard email type picklist values are configured
Solution 2:
- The legacy picklist Id field should have code ecEmailType.
See Also
Keywords
Error, code, 16, dashboard , BPE, message, email, type, has, occurred, please, contact, the system, administrator, ecEmailType, An error has occurred, please contact the system administrator, Unable to insert data due to a server error Please try again, [Error Code: 16] , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem
Product
SAP SuccessFactors Onboarding all versions