Symptom
Sync fails with error message Postal code must have length X from Gmail to SAP.
Where X is a number not set for the country where the postal code should be matched to.
Environment
Cloud For Customer.
Reproducing the Issue
- Create contact on c4c.
- Force sync contact with gsuite.
- update the contact on gsuite side(phone number as an example).
- On sync back to c4c issue happens where postal code length is too large despite it not being changed.
Cause
The Contact is not fully maintained in Gmail. Hence when it returns to C4C via sync some data will be interpreted wrongly.
Resolution
Make sure all fields are maintained in Gmail/Gsuite side.
As an example, despite postal code and address being completely filled correctly if the country is not set as well improper country will be interpreted upon sync.
Keywords
Google, Gsuite, Sync, Integration, C4C, Outlook. , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To