Symptom
E-signature for the candidate is not triggering
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Check that Click to Sign is enabled.
- Get the Process Id of the affected candidate.
- Filter for the candidate in the Variable field using onboardingProcessId="enter candidates ProcessId).
- See that there is an unfinished task.
- Check the Business Process Tile for any Errors.
- See error;
Document generation
HCP Error Message: Http Status Code 400
Document generation
Operation /odata/DataSchema (for FormId "") returned status code 400
Document generation
HCP Response Content: {"error":{"code":"1400","message":"The template does not exist. Check your request conditions."}}
Cause
- Documents are not present in PFS
- Documents have not synced correctly in PFS
Resolution
- Check your Print Form Services (PFS) to see if the documents mentioned in the BPE error are present.
- If they are remove them and then re-add these documents from maintain Onboarding and Offboarding Document Template page, once that is done the documents will be synced in the PFS account.
- Once the documents have been re-added, restart the task from business process tile.
Keywords
SuccessFactors Onboarding, SF Onboarding, PFS, Print Form Services, E-signature , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , Problem
Product
SAP SuccessFactors Onboarding 2305
SAP Knowledge Base Article - Public