SAP Knowledge Base Article - Public

3458633 - How Products are Sorted in a List Based on the Workcenter

Symptom

Do products get sorted differently depending on the workcenter they're in, even when using the same Ascending sorting setting?

Environment

SAP Business ByDesign 

Reproducing the Issue

  1. Go to Service Order Workcenter
  2. Filter by All Orders
  3. Search Service Order
  4. Sort Services and Spare Parts by 'Product ID' in Ascending Order

Now,

  1. Go to Inbound Delivery Notifications Workcenter
  2. Filter by All Delivery Notifications by Selection
  3. Search Delivery Notification ID
  4. Sort Delivery Notification items by 'Product ID' in Ascending Order

Although the list of product ID values is the same and the Inbound Delivery Notifications are related to the Service Order, the order of the items is not identical when sorted in ascending order by the Product ID.

Cause

The sorting will vary due to the use of different BOs(Business objects) and data types for the fields. Moreover, in the service order, the product is combined with the description.

Resolution

This is the expected system behavior.

Keywords

sorting logic , product ID , ascending order , sorting, list , workcenter , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , AP-PRD-MAT , Material , SRD-MD-PRD-PRD , Product , Problem

Product

SAP Business ByDesign all versions