Symptom
Do products get sorted differently depending on the workcenter they're in, even when using the same Ascending sorting setting?
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Service Order Workcenter
- Filter by All Orders
- Search Service Order
- Sort Services and Spare Parts by 'Product ID' in Ascending Order
Now,
- Go to Inbound Delivery Notifications Workcenter
- Filter by All Delivery Notifications by Selection
- Search Delivery Notification ID
- Sort Delivery Notification items by 'Product ID' in Ascending Order
Although the list of product ID values is the same and the Inbound Delivery Notifications are related to the Service Order, the order of the items is not identical when sorted in ascending order by the Product ID.
Cause
The sorting will vary due to the use of different BOs(Business objects) and data types for the fields. Moreover, in the service order, the product is combined with the description.
Resolution
This is the expected system behavior.
Keywords
sorting logic , product ID , ascending order , sorting, list , workcenter , KBA , AP-RC-UIF-RT-B , ByD HTML5 Client (not for Cloud for Customer) , AP-PRD-MAT , Material , SRD-MD-PRD-PRD , Product , Problem