Symptom
After clicking on the reset icon, SAC remains in a loading state and the story can no longer be used.
In Developer Tools, you can see the following error messages in the console log:
- Uncaught (in promise) TypeError: v.forwardConvertBookmark is not a function
at p.<anonymous> (app.chunk.story2-chunk.5269fb93e161db00e2cb.js:1:738994)
at app.main.93e64894b7135bdf97b5.js:101:106822
at Object.next (app.main.93e64894b7135bdf97b5.js:101:106927)
at app.main.93e64894b7135bdf97b5.js:101:105848
at new Promise (<anonymous>)
or
- 114.main.a159f8f….js:31 Uncaught (in promise) Error: [FailedAction - Action: store.createInstance@[{"app":"MAIN_APPLICATION"},{"undoRedoStack":"undoRedoStack"}] - Error: Store.CanNotRecreateInstance/Cannot create [{"app":"MAIN_APPLICATION"},{"undoRedoStack":"undoRedoStack"}], instance already exists.]
Environment
SAP Analytics Cloud (Enterprise) 2024.2.16
Reproducing the Issue
- Login SAC;
- Open the story;
- Go to Edit mode;
- Verify that the option "All Widgets in the Story" is selected on path: Select chart> 3 dots> More Options> Linked Analysis> Settings;
- Go to View mode;
- Create a new bookmark;
- Save it;
- Go to Bookmark > Open Saved Bookmarks> TEST P1 NEW;
- In the story select a dimension;
- It will appear the icons of "filter" and "exclude". Select the filter icon;
- The page changes and you can notice on the tool bar that the button of reset is there;
- Open the Dev tools (Ctrl+Shit+I);
- Press reset button;
- A warning pop up will appear. Select Reset;
- The story keeps loading.
If press the Reset button again, then you can see the story and use it again.
Cause
The bug is because there are two kinds of bookmarks to apply - and the "reset" button tries to apply "classic story style" bookmark, which is incorrect. "Reset" button should check the bookmark style and apply the bookmark as a new stack bookmark.
Resolution
Code changes to the issue have been submitted into 2024.8.8-0000008 and any later versions (2024.10, 2024.11, 2024.12,...).
The development team does not know the exact deployment timeline. You may want to check whether the SAC tenant is updated and whether the bug is fixed.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening a case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using SAP for Me, Google or Bing:
- https://me.sap.com/servicessupport/search#?q=SAP%20Analytics%20Cloud%20OR%20SAC&tab=All
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
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