SAP Knowledge Base Article - Public

3458882 - Email locale language not set as the rule - Onboarding

Symptom

The language is not being set as the candidate locale even if the rule is configured for that.

Environment

SAP SuccessFactors Onboarding

Cause

The rule was created based on the field "Native Preferred Language", however this field is not filled to the candidate in this step

Resolution

To ensure this field is populated during candidate initiation, please follow these steps:

For candidates initiated from RCM:

Navigate to Recruit-to-Hire Data Mapping

  1. Map the field "Native Preferred Language" under the personalInfo entity
  2. Ensure that this field is filled in at the RCM end
  3. Initiate Onboarding for the candidate
  4. Once these steps are completed, the field should populate, and the rule should work.

For candidates initiated manually:

While creating a candidate, select the "Provide Additional Data" option (instead of the "Initiate Onboarding" option), and fill in the field.

If even the field is mapped in RCM this still is not working, please check the following:

  1. Go to Manage Business Configuration 
  2. Find the field 'Native Preferred Language'
  3. Click to see the details
  4. Find the picklist associated with the field
  5. Go to Picklist Center > search for this picklist
  6. Ensure that the 'Non-unique External Code' is configured
  7. Ensure that the this picklist is exactly the same configured to RCM field

See Also

3006185 - How to Select Email Message Locale Based on Rule Scenario for Multiple Locales - Onboarding

Keywords

Onboarding, obx, language, locale, native, preferred, language, set, welcome, candidate, user, english, standard , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions