Symptom
After click on "Preview" in a Table report for Employee Central or Employee Profile data, an application error is thrown. The report is also not downloaded or run online.
Environment
SAP SuccessFactors Employee Central
SAP SuccessFactors Employee Profile
Reproducing the Issue
- Go to Reports Center and create a report of type Table
- Fill with Job Information columns
- Click on "Preview"
- Application error appears
While loading the report online, it keeps loading and does not open.
Cause
Potential Causes of the Application Error:
-
A custom field of data type "User" is configured on a standard object (such as Division, Department, or Business Unit) and has the Transient property set to Yes.
-
A Date field is used as a Filter with an invalid Date and Time format.
Resolution
-
While it is technically possible to add a custom field with the data type "User" to company structure objects (e.g., Division, Department, or Business Unit), setting the Transient property to Yes will cause failures in table reports.
To resolve this:-
Set the Transient property of the custom field to No.
-
This change can be made in Configure Object Definitions:
-
Select the affected object (e.g., Division, Department, etc.).
-
Locate the custom field with data type User.
-
Change the Transient setting to No.
-
-
Alternatively, you may disable the field if it's not required, which will also prevent the error.
-
-
Ensure any Date field used as a filter contains a valid date and time format.
-
The correct format is:
MM/DD/YYYY hh:mm:ss AM/PM
-
Example:
06/11/2025 03:45:00 PM
-
Keywords
application error, report error, report does not load, report not loading, table report, user, data type, division, department, business unit, company structure, employee central, transient, fingerprint=ddb24138a06f9596cb9b757f67dfa57ee9096554 , KBA , LOD-SF-EC-REP , Reporting Data (EC core only) , LOD-SF-EP-REP , Ad Hoc Report (Employee Profile) , Problem