SAP Knowledge Base Article - Public

3459049 - Application error when restarting in BPE: Manage Process Tasks after initiating onboarding from Recruiting and the candidate does not appear on the dashboard - Onboarding

Symptom

  • Candidate does not appear on the dashboard after initiating Onboarding from Recruiting.
  • The application error appears when restarting task in BPE: Manage Process Tasks.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Initiate an onboarding process from Recruiting.
  2. Unable to see the candidate in the onboarding dashboard.

Cause

  • It's a mapping issue.
  • Different data types are used for the same field mapped between RCM and EC when mapping.

Resolution

While mapping, the same data type should be used for the same field between RCM and EC to ensure that the data can be transferred without problem.

Please ensure that it is the picklist field in Recruiting that passes the value to the picklist field in EC, or the object field in Recruiting that passes the value to the object field in EC.

Passing a picklist field value to an object field is not accepted by the system.

Please check and modify the field data type configured in the RCM template or Manage Business Configuration.

(For SAP Support only: please see internal memo)  

Keywords

OBX, Onboarding, Data Type, Object, Picklist, Recruit-to-Hire Data Mapping, picklist option id, unknown label, picklist configuration, Manage Business Configuration, BCUI, RCM Template , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem

Product

SAP SuccessFactors Onboarding all versions