Symptom
When searching for a customer to add to a route template, they do not appear unless the query is changed
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to Work Center Visits > Routes
2. Select filter "All Routes and Templates"
3. Open Template "ABC" (ABC stands for the template name)
4. Select an existing customer in "Proposed Visits" in route template and click "Add"
5. Change query to "All Customers"
6. Search for customer "XYZ" (XYZ stands for the customer name) and add to the template
7. Go to the next day and add again a different customer
8. Observe the customer "XYZ" is still present, but no result is found
9. Clear the search and press enter but the list remains blank
10. When changing the query from "All Accounts" to "My Accounts" and back to "All Accounts", the result list shows customer again.
Cause
This is a known system limitation.
Resolution
As a workaround, you would need to change the query (eg. from "All accounts" to "My Accounts" and back to "All Accounts").
Keywords
proposed, Visits, Routes, Customer, template, preset, pre-set, "My Accounts", select, change query, result list, remains blank , KBA , AP-RC-UIF , C4C UI Framework , Problem