SAP Knowledge Base Article - Public

3459427 - Changes in Activity Plan Not Reflected To Visits

Symptom

You defined an activity plan and a visit was affected by it. You change the activity plan and expect the visit to behave as per your new definitions.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Activity Planner work center.
  2. Select the Plans view.
  3. Open Activity Plan ABC (where ABC is the ID of an activity plan).
  4. Edit it.
  5. Go to the Visits work center.
  6. Select the Visits view.
  7. Open Visit DEF (where DEF is the ID of a visit).
  8. Click in the Actions -> Refresh From Activity Plan OR
  9. Do an action that will trigger the activity plan.

You expected to see your new definitions of the activity plan affecting the visit.

Cause

 Once a visit is affected by an activity plan, the way it affects the visit will be stored inside it. Visit does not look into the AP definition to see how it should work every time so changes in AP will NOT be reflected into the visit.

Resolution

This is the system current standard behavior. 

See Also

2792961 - Activity Plans do not delete Surveys or Tasks when the Routing Rules Conditions are not met anymore

Keywords

Activity, plan, plans, changes, edit, reflected, not, working, visit, visits, anymore , KBA , LOD-CRM-ACT-VST , Visit Planning , LOD-CRM-ACT-ROT , Activity Routing , Problem

Product

SAP Cloud for Customer core applications 2402