Symptom
When a business user from China (CST) timezone logs into C4C, the 'Creation Date' and 'Requested Date' fields in the Sales Order display dates such as 20-Jan-2024.
However, when an user from New York (EST) timezone logs in, the 'Creation Date' and 'Requested Date' fields show different dates. For example, the 'Creation Date' shows as 19-Jan-2024, while the 'Requested Date' as 20-Jan-2024.
Please notice the mentioned dates and time zones are just an example, this document is valid for any dates and time zones.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Login with a user from, for example, CST timezone;
- Go to Sales > Sales Order;
- Open a Sales Order;
- See Creation Date and Requested Date shows, for example, the date 20-Jan-2024;
- Sign out;
- Login with a user from, for example, EST time zone;
- Repeat steps 2 and 3;
- See Creation Date and Requested Date fields shows different dates, for example, the date 19-Jan-2024 and 20-Jan-2024 respectively.
Cause
The Requested Date and Creation Date fields will not always show the same dates.
The Requested Date field can be defined in Fine tune activity "Date Profile" i.e. Requested Date = Creation date + define (either 0/1/2/3..day/s). So first of all, you need to check how those fields were setup.
If it was maintained Requested Date = Creation Date + 0 days - then it means Creation Date and Requested Date should be the same.
So, when any user will create a Sales Order, Creation Date and Requested Date auto determine same date. However, user still has option to change the Requested Date manually to another date in QC (quick create) screen.
For example, if a Sales Order was created on 19.01.2024 at 23:50 (UTC+00 which is the backend default time), the Creation Date will be 19-Jan-2024 and Requested Date 20-Jan-2024 for New York user (EST), while China user (CST) Creation Date and Requested Date will be 20-Jan-2024, because China is 12 hours ahead of New York time:
Also, please note that if Requested Date is in the past, then this is only possible if user choose Requested Date in QC screen or due to a PDI.
Therefore, the Requested Date is a date field, so it won’t change (unless someone manually changes it in QC screen). While Creation Date is a date and time field so it will change depending on the business user time zone that is logged in the system.
Resolution
This is the expected system behavior.
We are constantly thriving to improve our system and hearing your suggestions is the best way forward. Our product managers regularly check the Influence page to hear what changes users would like to see in place and check those for feasibility. Idea requests can also be voted for by other customers.
If you would like to suggest a change to this behavior, please submit your idea at the respective SAP Influence page:
Please note that it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release.
Keywords
sales document, created date , KBA , LOD-LE-CQP-CO , Lean Sales Orders , LOD-LE-CQP , Customer Quote Processing , Problem