Symptom
The number of days between the last Visit date and today is not equal to the number of days seen in Visit Overdue in Cockpit
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Dynamic Visit Planning Workcenter.
- Go to Cockpit Workcenter View.
- Select any Account that is overdue for a visit.
- Let the number of days seen in the Visit Overdue be 'X' days.
- Go into the account and check the last Completed Visit to see the Last Visit Date.
- The number of days between Last Visit Date to Today is not 'X' days as seen in Cockpit.
Cause
The visit overdue days are calculated based on Due date and not Last Visit date. The Due date is derived based on last completed visit date + frequency and can be seen under the Visit Information facet of the particular account.
So, when we say 'Overdue', it is always from the date we were supposed to visit the account but did not. When you consider last visited date, we have already completed that visit, so we are not really overdue to visit the account until the next due date.
Resolution
This is the expected system behaviour.
See Also
https://help.sap.com/docs/SAP_CLOUD_FOR_CUSTOMER/9f548c3c8a5f4ce28253c9368eef5ff3/cbf94b1406364530931aa51612371776.html?q=visit%20overdue#loio17ad01050d204836b1dc3d35d4f84710
https://help.sap.com/docs/SAP_CLOUD_FOR_CUSTOMER/9f548c3c8a5f4ce28253c9368eef5ff3/92f0bc4561044100ae6852b5f6d9b345.html?q=due%20date
Keywords
DVP, Cockpit, due, date, last, visit, date, visit overdue, overdue, visit, account, visit information, incorrect , KBA , LOD-CRM-DVP , SAP Sales Cloud, dynamic visit planning add-on , Problem