Symptom
Specified value XXX is not valid.
Environment
- SAP Cloud for Customer.
Reproducing the Issue
- Go to the Administrator work centre -> Webservice Message Monitoring.
- Find the erroneous message and click on error log.
- You find "<ERROR_TEXT>Specified value XXX is not valid</ERROR_TEXT>" .
- Search the payload for the value XXX and see if it is assigned as an extension field. Should look like "<ns1:Field name xmlns:ns1="http://sap.com/xi/AP/CustomerExtension/BYD/AAAA">XXX</ns1:Field name>".
Cause
The error is "Specified value XXX is not valid " and is due to value XXX unavailable in the pick list of custom field "Field name".
<ns1:Field name xmlns:ns1="http://sap.com/xi/AP/CustomerExtension/BYD/AAAA">XXX</ns1:Field name>
Resolution
Please add this value to the pick list of the custom field and then restart the message which should be successfully processed.
Keywords
Cloud for Customer, CustomerExtension, Integration , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem
Product
SAP Cloud for Customer add-ins 2024 ; SAP Cloud for Customer core applications 2402