Symptom
An error message stating "Only HTML files can be uploaded" appears when attempting to update the workflow template.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Navigate to the Service
- Proceed to the Templates
- Search for ''All Workflow Notification Templates''
- Select the problematic template
- Look for the ''File Name'' field and click on ''Replace''
- Choose a Template
- Save
- Notice: An error stating "Only HTML files can be uploaded" appears.
Cause
The custom extension code starting with Z could cause this issue.
Resolution
Please follow these steps to remove the file extension for the MIME type "application/html" and then upload the file.
1. Navigate to Business Configuration.
2. Click on Navigate, then select Overview.
3. Search for the 'Allowed MIME Types for Document Upload' activity.
4. Select the MIME type "application/html".
5. Remove the file extension codes "Z"
6. Click on Save and Close.
Keywords
Mime Type, HTML, Extension Code Z, Zhtml , Template , KBA , LOD-CRM-WKF , Workflow , Problem