Symptom
The Visit that was created for a customer does not display their existing Appointments in the Follow-up Items facet.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Visits > Visits;
- Open any Visit;
- Go to Follow-up Items facet;
- Notice there are no Appointments for the visit, even though customer has existing Appointments in the system.
Cause
Appointment is a very broad definition which includes all possibilities of customer interaction like Telephone Call, Workshop, Customer visit, Product Presentation, Meeting, Service Order, etc. However, Visit is a very specific interaction which involves meeting the customer physically. Of course, Customer visit is also a type of appointment.
Anything created as customer visit in appointment will not appear in Visits and vice versa. They are different from a system handling perspective.
The Visits functionality involves much more with respect to route planning, consumption of Surveys, Campaigns, etc. In the Appointment, Customer visit can be followed up to create an actual Visit and also vice versa.
Resolution
This is the expected system behavior.
We are constantly thriving to improve our system and hearing your suggestions is the best way forward. Our product managers regularly check the Influence page to hear what changes users would like to see in place and check those for feasibility. Idea requests can also be voted for by other customers.
If you would like to suggest a change to this behavior, please submit your idea at the respective SAP Influence page:
Please note that it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release.
Keywords
account, individual customer, activity, activities , KBA , LOD-CRM-ACT , Activities , LOD-CRM-ACT-VST , Visit Planning , Problem
SAP Knowledge Base Article - Public