SAP Knowledge Base Article - Public

3461594 - Error "We were not able to verify your account. Check your login credential and try again" happened when click Verify Account for step 4 of configuring custom IDP in SAP Analytics Cloud (SAC)

Symptom

In step 4 of configuring custom IDP in SAC by following the steps in the SAC help guide Enable a Custom SAML Identity Provider, click the Verify Account button. The following error message pops up:

  • "We were not able to verify your account. Check your login credential and try again"

The below error can be seen in web browser HAR trace:

  • errorDetails: [{message: "uploadIdPMetadata failed with 500 status", bUIMessage: false, bWarning: false}]
    1. 0: {message: "uploadIdPMetadata failed with 500 status", bUIMessage: false, bWarning: false}
      1. bUIMessage: false
      2. bWarning: false
      3. message: "uploadIdPMetadata failed with 500 status"
      4. message: "uploadIdPMetadata failed with 500 status"
      5. stack: ""
      6. status: 500

Environment

  • SAP Analytics Cloud (Enterprise)

Reproducing the Issue

  1. Login to SAC.
  2. Go to System -> Administration -> Security.
  3. Upload SAML IDP metadata.
  4. Click verify account.
  5. Notice that error happens.

Cause

In the IDP metadata, it id found the Subject and Issuer of certificate are set to IP Address like below:

Resolution

Configure SAML IDP certificate to have a valid CN and Issuer of a hostname instead of IP address.

Keywords

SAC, IDP, Verify Account, Custom. , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud all versions

Attachments

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