SAP Knowledge Base Article - Public

3461797 - Ask HR: error on line 1 at column 1: Start tag expected, '<' not foundBelow is a rendering of the page up to the first error

Symptom

When accessing your Ask HR (ECSC) application, the following error occurs:

Something went wrong! Please contact your system administrator. This page contains the following errors:error on line 1 at column 1: Start tag expected, '<' not foundBelow is a rendering of the page up to the first error.


Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central Services Center

Cause

Customer configuration.

Resolution

With 1H 2024 Release, Ask HR Engineering have introduced a feature which relies on the SuccessFactors' settings in MDF.
What this means is that, if your SuccessFactors tenant is still on the 2H 2023 version (2311) but you have subscribed to "SAP SuccessFactors Employee Central Services Center (Preview)" service in BTP (which is already running on the 1H 2024 code since 19th April), then an inconsistency will arise, and you will experience the above-mentioned error (for example, you will experience this error if you are connecting a Productive SuccessFactors tenant to the service Preview version of the service in BTP; this will happen at least until May 17th, when all Productive SuccessFactors environments will be upgraded to 1H 2024).

BTP environment > Services:



To address this error, since your SuccessFactors tenant is on a 2311 build, please subscribe to an ECSC Production service (which currently is built against the 2311 SuccessFactors build) and the error will no longer occur.
IMPORTANT: As a best practice, please ensure you are not mixing production and preview environments between your SuccessFactors and BTP subscriptions; your mapping should be set up as follows:

SF (preview) + ECSC (preview) service
SF (production) + ECSC (prod) service

If the wrong service is being used:

  1. Refer to Subscribing to the Ask HR Application on SAP Business Technology Platform in order to enable the correct service (SAP SuccessFactors EC Service Center (Preview) or SAP SuccessFactors EC Service Center (Production))
  2. To check about any possible costs, or if the correct service does not appear at the BTP Account, contact the SAP Account Executive as described at 2626344 - Who is the SAP Account Manager for my company?

Please also note, once the Major Upgrade to 1H 2024 happens in Production SuccessFactors environments, the issue will no longer occur.

See Also

Implementing Service Center in Employee Central

Keywords

Something went wrong! Please contact your system administrator.This page contains the following errors:error on line 1 at column 1: Start tag expected, '<' not foundBelow is a rendering of the page up to the first error, AskHR, Ask HR, ECSC, EC Services Center, EC Services Centre, Employee Central Services Centre, Employee Central Services Center, Production, Preview , KBA , LOD-SF-INT , Integrations , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem

Product

SAP SuccessFactors HCM Core all versions