SAP Knowledge Base Article - Public

3461815 - Business data fields within the sales order are blanked out during processing

Symptom

After filling incoterms in the sales order, the field is immediately removed. The same can be seen for other fields such as customer reference and incoterms location.

Environment

  • Sales and Distribution (SD)
  • SAP S/4HANA Cloud All versions 

Reproducing the Issue

  1. Logon to the launchpad with role SAP_BR_INTERNAL_SALES_REP assigned
  2. Select tile Change Sales Orders - VA02.
  3. Open a sales order and fill fields Cust. Reference and Incoterms.
  4. After pressing enter the fields disappear.

Cause

If BAdI SD_SLS_MODIFY_HEAD_BUSINESS is active on the system. It is a requirement, at minimum to copy the values from the SALESDOCUMENT parameter to the SALESDOCUMENT_BUSINESSDATA. For example: via the MOVE_CORRESPONDING statement. Otherwise, the values existing in the business fields before the call will be deleted.

Resolution

Please ensure that SALESDOCUMENT_BUSINESSDATA contains the correct data in SD_SLS_MODIFY_HEAD_BUSINESS.

Keywords

SD_SLS_MODIFY_HEAD_BUSINESS, PRICINGDATE, PURCHASEORDERBYCUSTOMER, CUSTOMERPURCHASEORDERDATE, INCOTERMSVERSION, INCOTERMSCLASSIFICATION, INCOTERMSLOCATION1, INCOTERMSLOCATION2, IF_SD_SLS_MODIFY_HEAD_BUSINESS~MODIFY_BUSINESS_DATA, CL_SDOC_MODIFY_BUSINESS_DATA, salesdocument, VA01, VA02, VA11, VA21, Va31, VA41, VA12, VA22, VA32, VA42, order, quotation, contract, Manage sales order, F3893, F1873, custom logic , KBA , SD-SLS-EXT-2CL , Extensibility (Public Cloud) , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions