SAP Knowledge Base Article - Public

3462048 - Standard Interface Does Not Work in Custom Web Service

Symptom

You have created a custom web service using standard interface and it is not giving any response; 

Environment

  • SAP Cloud for Customer
  • SAP Cloud Applications Studio

Reproducing the Issue

  1. Go to SAP Cloud Applications Studio.
  2. Create a Custom Web Service. 
  3. On frontend, go to Administrator > Service Explorer. 
  4. Select an Standard Service Interface.
  5. Click on Download .WSDL.
  6. Upload downloaded .wsdl file to the Custom Web Service created.
  7. Save and Activate. 
  8. When running it, it gives no response. 

Cause

The standard usage of these standard interfaces work fine because the technical IDs and configuration have been manually filled in the SOAP Manager by SAP. When using it in SAP Cloud Applications Studio, this creates new generated ABAP classes and some of configurations might not be properly replicated. 

Resolution

In SAP Technical Support, we don't provide assistance for the utilization of standard interfaces within custom web services. Responsibility for managing the consistency of standard interfaces and their metadata (e.g. .csd, .wsdl). in custom web services rests with the creator of the PDI Solution.

See Also

Create a Web Service

Modify an External Web Service Integration (SOAP) 

Keywords

standard interface, custom web service, pdi, solution, wsdl,  , KBA , AP-RC-BDS-WS , ByDesign Studio Web Services , How To

Product

SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions