SAP Knowledge Base Article - Public

3462054 - Error "Change of party not permitted; contract exists on item" Raised when a Follow-Up Sevice Order is Created from a Contract using a Registered Product

Symptom

When creating a follow-up Service Order from a Contract and inputting a Registered Product, the error "Change of party not permitted; contract exists on item" is raised and the Service Order becomes Inconsistent.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Entitlements work center.
  2. Open the Contracts view.
  3. Find Contract ABC (Where ABC Represents the ID of the Contract you wish to create a follow-up Service Order from).
  4. Highlight the Contract and click the 'Follow-Up" button, then click the "Service Order" option.
  5. In the New Service Order screen, click on View All.
  6. Navigate to the Account and Affected Product tab .
  7. Input Registered Product DEF (Where DEF Represents the ID of the Registered Product).

The error "Change of party not permitted; contract exists on item" is raised.

Cause

A possible cause for this error to be raised in this scenario is due to an inconsistency during the determination of Involved Parties in the document.

Resolution

In order to correct the error, a dummy change needs to be performed in the Sales Unit of the document:

  1. Go to the Service Entitlements work center.
  2. Open the Contracts view.
  3. Find Contract ABC (Where ABC Represents the ID of the Contract you wish to create a follow-up Service Order from).
  4. Highlight the Contract and click the 'Follow-Up" button, then click the "Service Order" option.
  5. In the New Service Order screen, click on View All.
  6. Navigate to the Account and Affected Product tab .
  7. Input Registered Product DEF (Where DEF Represents the ID of the Registered Product).
  8. Navigate to the Involved Parties tab.
  9. Remove Sales Unit GHI from the Involved Parties (Where GHI Represents the ID of the Sales Unit of the Service Order).
  10. Press ENTER.
  11. Input the Sales Unit GHI back in the Involved Parties.

This allows the system to successfully redetermine the Involved Parties in the document and for the document to be saved.

Keywords

Service Order, Contract, Follow Up, Error, Inconsistent, Inconsistency, Unable, Registered Product, masterdata, party, parties, not possible, not permitted. , KBA , SRD-CRM-SEO , Service Orders , How To

Product

SAP Business ByDesign all versions