SAP Knowledge Base Article - Public

3462244 - Emails not getting triggered for custom new hire task using the "(ONB) Custom Task Completion Trigger" or custom email trigger - Onboarding

Symptom

Emails not getting triggered for custom new hire task using the "(ONB) Custom Task Completion Trigger" or custom email trigger.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Add a template with trigger : (ONB) Custom Task Completion Trigger or a custom email trigger
  2. Once the custom new hire task is completed the email is not triggered.

Cause

The custom new hire task is not mandatory.

Resolution

  • The custom new hire task should be made mandatory.
  • Once the task is mandatory, the email will be triggered.
  • If the custom new hire task is set to Optional, the email will not be sent, even if a business rule is set.

Keywords

Custom Task, Custom Task Completion Trigger, Email, Task Email, Custom Task Completion, Email Services, Custom New hire task , KBA , LOD-SF-OBX-NHA , New Hire Activities (activities, tasks, buddy, equipment) , Problem

Product

SAP SuccessFactors Onboarding all versions