Symptom
You notice that, although you have confirmed an Individual Customer, Account, Employee or Supplier in the Agent Desktop, after creating a case from within the respective hub (Customer Hub, Employee Hub or Supplier Hub), the respective case field does not display the related business partner.
Environment
SAP Service Cloud Version 2.
Reproducing the Issue
- Logon to your V2 environment.
- Navigate to Agent Desktop work list.
- Search and confirm the respective business partner e.g. Individual Customer XX.
- Open the Customer Hub.
- Click + Create.
- Click Case.
- Fill in all mandatory details.
- Click Save and Open.
- In the created case, see the field Individual Customer is empty, although you created the case from within the customer hub of a confirmed individual customer.
Cause
This is the system designed behavior in case the field which corresponds to the business partner confirmed e.g. Individual Customer is hidden in the case create screen.
Resolution
It is required to ensure that, the fields which correspond to the business partner confirmed are visible in the case creation screen, as only for visible fields the values will be considered for case creation.
Keywords
Case, Agent Desktop, Customer Hub, Case Create, Create, Creation, BP, Business Partner, Account, Individual Customer, Employee, Supplier, Field, Empty, Blank, Case Field, Hidden, Field Hidden, Hidden Field, Value, SAP Service Cloud Version 2, V2, , KBA , CEC-CRM-AD , Agent desktop - live channels , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , How To